This config sample is from an ECS2100 configuration where:

  • VLAN trunks/uplinks on copper uplink port 1 & all fibre ports (1,25-28)
  • Management VLAN = 1 on copper uplink port 1 & all fibre ports (1,25-28)
  • Voice VLAN = 100 on all ports
  • Data VLAN = 200 on all ports
  • Untagged traffic on ports 2-24 is assigned to VLAN 200 i.e. the data network
  • IP management of the switch is on VLAN 1 DHCP client (please change this accordingly)
  • LLDP-MED voice features are switched on to auto assign IP handsets to VLAN 100
  • IGMP multicast help enabled on all VLANs


Below is a full configuration example i.e. 'show running-config'. NOTE: See further below this for a shortcut to programming this configuration on a factory default switch.


!
sntp server 216.239.35.0 103.242.70.5 202.78.240.38
!
clock timezone-predefined GMT+1200-Auckland,Wellington
!
ntp client
!
hostname ECS2100
snmp-server location "13 Beatrice Tinsley Cres, Albany, Auckland, NZ"
snmp-server contact support@snappernet.co.nz
!
!
!
clock summer-time NZDT predefined new-zealand
!
!
!
snmp-server community public ro
snmp-server community private rw
!
!
!
enable password 7 1b3231655cebb7a1f783eddf27d254ca
!
!
!
!
no logging sendmail
!
!
!
vlan database
 VLAN 1 name DefaultVlan media ethernet
 VLAN 100 name VOICE media ethernet
 VLAN 200 name DATA media ethernet
!
!
!
!
!
!
!
!
!
spanning-tree mst configuration
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface ethernet 1/1
 switchport allowed vlan add 1,100,200 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/2
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/3
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/4
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/5
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/6
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/7
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/8
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/9
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/10
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/11
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/12
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/13
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/14
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/15
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/16
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/17
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/18
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/19
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/20
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/21
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/22
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/23
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/24
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/25
 switchport allowed vlan add 1,100,200 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/26
 switchport allowed vlan add 1,100,200 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/27
 switchport allowed vlan add 1,100,200 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
interface ethernet 1/28
 switchport allowed vlan add 1,100,200 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
 
!
!
!
!
!
interface vlan 1
 ip address dhcp
!
!
!
!
!
ip name-server 8.8.8.8
ip domain-lookup
!
!
!
!
!
!
!
!
!
ip igmp snooping
ip igmp snooping proxy-reporting
ip igmp snooping unregistered-data-flood
ip igmp snooping querier
ip igmp snooping vlan 1,100,200
!
!
voice vlan 100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface vlan 1
!
!
!
!
!
!
line console
!
!
line vty
!
!
!
end
!



An easy way to configure this is at the command line, either telnet or serial (recommended - 115200,8,1,n,1)

configure
interface ethernet 1/1,25-28
 switchport allowed vlan add 1,100,200 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
exit

interface ethernet 1/2-24
 switchport allowed vlan add 200 untagged
 switchport native vlan 200
 switchport allowed vlan add 100 tagged
 switchport voice vlan auto
 switchport voice vlan rule lldp
exit

voice vlan 100

exit

copy running-config startup-config



  • Most modern phones will boot, read the LLDP-MED message from the switch port to get its VLAN hint, restart its network with the correct VLAN tagging inserted.
  • PCs connected directly to the switch will be on VLAN 200
  • PC's connected via the phone PC port should land on the default VLAN 200


Check your work at the CLI with the command 'show mac-address-table'.